HUAWE配置BGP MED属性控制路由选路

组网需求

  所有路由器都配置 BGP,R1 属于 AS 65008,R2、R3 属于 AS 65009。

06net.com路由器怎么设置

  R1 与 R2、R3 之间运行 EBGP,R2 与 R3 之间运行 IBGP。 06net.com路由器怎么设置

  R2、R3 发布 10.1.23.0/24 网段

06net.com路由器设置

   无线路由器设置06net.com

 

06net路由器网

  配置思路 06net

  R1 与 R2、R3 之间配置 EBGP 连接,R2、R3 之间配置 IBGP 连接。

06路由器网

  方案一:通过路由策略调大 R2 发给 R1 的 MED 值,使得 R1 选择 R3 作为出口。 06net

  方案二:通过路由策略调大 R1 接收 R2 的 MED 值,使得 R1 选择 R3 作为出口。 06net.com路由器怎么设置

  配置步骤

www.06net.com

  1、配置接口 IP 地址 无线路由器设置06net.com

  2、配置 AS 65009 IGP 06net.com

  3、配置 BGP 连接 无线路由器设置06net.com

  dis bgp routing-table 10.1.23.0

路由器怎么设置06net.com

  BGP local router ID : 1.1.1.1

06net.com

  Local AS number : 65008 路由器设置06net.com

  Paths: 2 available, 1 best, 1 select

06路由器网

  BGP routing table entry information of 10.1.23.0/24:

06net.com路由器怎么设置

  From: 10.1.12.2 (2.2.2.2)

06net.com路由器设置

  Route Duration: 00h02m57s

无线路由器设置06net.com

  Direct Out-interface: GigabitEthernet0/0/0 www.06net.com

  Original nexthop: 10.1.12.2

06net.com

  Qos information : 0x0

06net

  AS-path 65009, origin igp, MED 0, pref-val 0, valid, external, best, select, active, pre 255 06net.com

  Advertised to such 2 peers:

路由器设置06net.com

  10.1.13.3 06路由器网

  10.1.12.2 06net.com

  BGP routing table entry information of 10.1.23.0/24: 06net.com路由器怎么设置

  From: 10.1.13.3 (3.3.3.3)

06net.com

  Route Duration: 00h02m57s 06net

  Direct Out-interface: GigabitEthernet0/0/1

路由器设置06net.com

  Original nexthop: 10.1.13.3

无线路由器设置06net.com

  Qos information : 0x0 www.06net.com

  AS-path 65009, origin igp, MED 0, pref-val 0, valid, external, pre 255, not preferred for router ID 路由器怎么设置06net.com

  Not advertised to any peer yet 路由器怎么设置06net.com

  4、配置 MED 属性 06net

  方案一:

路由器设置06net.com

  ==========R1========== 06net

  #

无线路由器设置06net.com

  route-policy set_med_in permit node 10 06net

  apply cost 100 无线路由器设置06net.com

  # 06net

  bgp 65008

06net.com

  #

06net

  ipv4-family unicast 无线路由器设置06net.com

  peer 10.1.12.2 route-policy set_med_in import

www.06net.com

  # 路由器怎么设置06net.com

  dis bgp routing-table 10.1.23.0 06net.com路由器设置

  BGP local router ID : 1.1.1.1 路由器设置06net.com

  Local AS number : 65008 06net

  Paths: 2 available, 1 best, 1 select

06net路由器网

  BGP routing table entry information of 10.1.23.0/24: 06net

  From: 10.1.13.3 (3.3.3.3) 06net

  Route Duration: 01h20m40s 06net.com

  Direct Out-interface: GigabitEthernet0/0/1 06路由器网

  Original nexthop: 10.1.13.3

www.06net.com

  Qos information : 0x0 06net.com路由器怎么设置

  AS-path 65009, origin igp, MED 0, pref-val 0, valid, external, best, select, active, pre 255 06net.com

  Advertised to such 2 peers:

路由器怎么设置06net.com

  10.1.13.3 06net.com

  10.1.12.2

06net.com

  BGP routing table entry information of 10.1.23.0/24:

www.06net.com

  From: 10.1.12.2 (2.2.2.2)

06路由器网

  Route Duration: 01h09m55s

路由器怎么设置06net.com

  Direct Out-interface: GigabitEthernet0/0/0

路由器怎么设置06net.com

  Original nexthop: 10.1.12.2 06net.com

  Qos information : 0x0 无线路由器设置06net.com

  AS-path 65009, origin igp, MED 100, pref-val 0, valid, external, pre 255, not preferred for MED

06net

  Not advertised to any peer yet

06路由器网

  方案二:

路由器设置06net.com

  ==========R2==========

06net.com路由器设置

  #

路由器设置06net.com

  route-policy set_med_out permit node 10 无线路由器设置06net.com

  apply cost 200 06net.com

  #

06net路由器网

  bgp 65009 06路由器网

  #

06net

  ipv4-family unicast 无线路由器设置06net.com

  peer 10.1.12.1 route-policy set_med_out export

路由器设置06net.com

  # 06net.com路由器怎么设置

  dis bgp routing-table 10.1.23.0

路由器怎么设置06net.com

  BGP local router ID : 1.1.1.1

路由器设置06net.com

  Local AS number : 65008

www.06net.com

  Paths: 2 available, 1 best, 1 select 06net.com路由器怎么设置

  BGP routing table entry information of 10.1.23.0/24:

06net路由器网

  From: 10.1.13.3 (3.3.3.3)

06net.com路由器设置

  Route Duration: 00h00m13s 06net路由器网

  Direct Out-interface: GigabitEthernet0/0/1

06路由器网

  Original nexthop: 10.1.13.3

06net.com

  Qos information : 0x0

06net.com路由器怎么设置

  AS-path 65009, origin igp, MED 0, pref-val 0, valid, external, best, select, active, pre 255

路由器怎么设置06net.com

  Advertised to such 2 peers:

06路由器网

  10.1.12.2

06net

  10.1.13.3

06net路由器网

  BGP routing table entry information of 10.1.23.0/24: 06路由器网

  From: 10.1.12.2 (2.2.2.2) www.06net.com

  Route Duration: 00h00m14s www.06net.com

  Direct Out-interface: GigabitEthernet0/0/0 06net.com路由器怎么设置

  Original nexthop: 10.1.12.2

路由器怎么设置06net.com

  Qos information : 0x0 06net.com路由器设置

  AS-path 65009, origin igp, MED 200, pref-val 0, valid, external, pre 255, not preferred for MED

06net

  Not advertised to any peer yet

路由器设置06net.com

  配置文件

06net.com路由器设置

  ==========R1========== 路由器怎么设置06net.com

  # 06net.com路由器怎么设置

  sysname R1 无线路由器设置06net.com

  #

06net.com路由器怎么设置

  interface GigabitEthernet0/0/0 www.06net.com

  ip address 10.1.12.1 255.255.255.0 路由器怎么设置06net.com

  #

06net路由器网

  interface GigabitEthernet0/0/1 06net.com

  ip address 10.1.13.1 255.255.255.0

www.06net.com

  # 06net路由器网

  interface LoopBack0 路由器设置06net.com

  ip address 1.1.1.1 255.255.255.255 06net.com路由器设置

  #

路由器设置06net.com

  bgp 65008

06net.com

  router-id 1.1.1.1

06net

  peer 10.1.12.2 as-number 65009 路由器怎么设置06net.com

  peer 10.1.13.3 as-number 65009

06net路由器网

  # 06路由器网

  ipv4-family unicast

www.06net.com

  undo synchronization

www.06net.com

  peer 10.1.12.2 enable 06net.com路由器怎么设置

  peer 10.1.13.3 enable

06net.com路由器怎么设置

  #

06net.com路由器怎么设置

  route-policy set_med_in permit node 10 06net.com路由器怎么设置

  apply cost 100 无线路由器设置06net.com

  # 路由器设置06net.com

  ==========R2==========

路由器怎么设置06net.com

  # 06路由器网

  sysname R2

06net.com路由器设置

  #

路由器设置06net.com

  interface GigabitEthernet0/0/0

www.06net.com

  ip address 10.1.12.2 255.255.255.0 06路由器网

  #

路由器怎么设置06net.com

  interface GigabitEthernet0/0/1

无线路由器设置06net.com

  ip address 10.1.23.2 255.255.255.0 06net.com路由器设置

  #

06net路由器网

  interface LoopBack0

路由器怎么设置06net.com

  ip address 2.2.2.2 255.255.255.255 06net.com

  #

www.06net.com

  bgp 65009

路由器怎么设置06net.com

  router-id 2.2.2.2

www.06net.com

  peer 3.3.3.3 as-number 65009

06net.com路由器怎么设置

  peer 3.3.3.3 connect-interface LoopBack0

06net.com路由器怎么设置

  peer 10.1.12.1 as-number 65008 路由器怎么设置06net.com

  #

06net.com

  ipv4-family unicast 06net.com

  undo synchronization

06net.com路由器怎么设置

  network 10.1.23.0 255.255.255.0

www.06net.com

  peer 3.3.3.3 enable 06net路由器网

  peer 10.1.12.1 enable www.06net.com

  peer 10.1.12.1 route-policy set_med_out export 06net.com路由器设置

  #

06net

  ospf 110 router-id 2.2.2.2 06net路由器网

  area 0.0.0.0

06net.com路由器怎么设置

  network 2.2.2.2 0.0.0.0 06net

  network 10.1.23.0 0.0.0.255 www.06net.com

  # 06net路由器网

  route-policy set_med_out permit node 10

无线路由器设置06net.com

  apply cost 200

路由器怎么设置06net.com

  # 路由器设置06net.com

  ==========R3========== 06net路由器网

  # 路由器怎么设置06net.com

  sysname R3 06net.com路由器设置

  #

06net路由器网

  interface GigabitEthernet0/0/0 06路由器网

  ip address 10.1.13.3 255.255.255.0 路由器设置06net.com

  #

06net

  interface GigabitEthernet0/0/1

06net.com路由器设置

  ip address 10.1.23.3 255.255.255.0

路由器怎么设置06net.com

  #

路由器设置06net.com

  interface LoopBack0 路由器设置06net.com

  ip address 3.3.3.3 255.255.255.255 06net.com路由器设置

  # 06net.com路由器怎么设置

  bgp 65009 06net

  router-id 3.3.3.3

无线路由器设置06net.com

  peer 2.2.2.2 as-number 65009

无线路由器设置06net.com

  peer 2.2.2.2 connect-interface LoopBack0 06net

  peer 10.1.13.1 as-number 65008

www.06net.com

  # 06net.com路由器设置

  ipv4-family unicast 路由器设置06net.com

  undo synchronization 路由器怎么设置06net.com

  network 10.1.23.0 255.255.255.0 06net.com

  peer 2.2.2.2 enable 路由器设置06net.com

  peer 10.1.13.1 enable 路由器怎么设置06net.com

  #

06路由器网

  ospf 110 router-id 3.3.3.3

06net路由器网

  area 0.0.0.0 路由器设置06net.com

  network 3.3.3.3 0.0.0.0 06net路由器网

  network 10.1.23.0 0.0.0.255

06路由器网

  # 06net.com

推荐阅读
启用全双工在一个较高的速度,可以提高工作效率的办公室或企业网络上的数据传输。双工模式允许进行双向通信,这意味着在相同的时间,数据可以被发送和接收。并非所有的路由器都具有此功能。对于那些做,确切的方法来启用它变化,所以考虑几个步骤。 请检查如果您的路由器已经在双工模式。某些路由器,如Linksys WRT54G,都配有一盏说:全/科尔。 恒亮时,此灯亮表示它对应的以太网端口在全双工模式下的连接。此灯可定期闪烁,但并...
来源:www.06net.com//所属分类: 路由器怎么设置/更新时间: 2013-08-05
相关路由器怎么设置